Fixed Issues

Issues that people reported that have since been fixed

FIXED: In Edge, YouTube videos show a black screen with AdBlock on
Update: This issue was fixed in AdBlock for Edge 1.5. Update November 10, 2016: We've confirmed this is a bug in AdBlock for Edge version 1.4. ...
Thu, 29 Jun, 2017 at 6:02 PM
FIXED: "Please try again" error when playing YouTube videos
Update March 17: Most people are reporting the error is no longer occurring. If you're still seeing it, please use the workarounds below. We'l...
Thu, 29 Jun, 2017 at 6:03 PM
FIXED: YouTube videos and Facebook Messenger website won't load
A couple of broken filters in EasyList this week caused YouTube videos and the Facebook Messenger website not to load. YouTube videos displayed an error suc...
Fri, 7 Jul, 2017 at 12:58 PM
FIXED: My custom filters are missing after upgrade to AdBlock 3.0!
If your custom filters are gone after the upgrade to AdBlock 3.0, first let us apologize for that. Our testing was extensive, but a bug slipped through ...
Thu, 29 Jun, 2017 at 6:03 PM
FIXED: Can't save web pages as HTML files with AdBlock on
If you're trying to save a web page as an HTML file in Chrome and the download hangs after a few kilobytes, we're pretty certain it's because...
Thu, 29 Jun, 2017 at 6:03 PM
FIXED: Acceptable Ads can't be disabled after update to AdBlock for Chrome 3.0
NOTE: This issue has been fixed. A bug that slipped through our QA testing is causing AdBlock for Chrome 3.0 not to save your setting for Acceptable...
Fri, 22 Jun, 2018 at 3:12 PM
My Facebook News Feed doesn't work after the last AdBlock for Safari update
If you use our legacy AdBlock for Safari extension and Facebook, you may have noticed that only one or two posts are appearing in your News Feed. You can&#x...
Tue, 28 Aug, 2018 at 10:39 PM
FIXED: I have Windows 10. When I try to install AdBlock in Edge, it tells me I need to upgrade Windows.
You are probably seeing this because your version of Windows 10 doesn't support Edge extensions. Please make sure that you're using the most rec...
Thu, 29 Jun, 2017 at 6:05 PM
YouTube video playback is delayed in Firefox
Occasionally we get reports from Firefox users that videos on YouTube start with several seconds of a black screen, after which they play normally. Pausing ...
Sun, 19 Feb, 2017 at 4:13 PM
FIXED: Links on t411.ch don't open in a new tab with AdBlock running
Some users have reported that they are unable to open links in a new tab using the middle mouse button or wheel on the website t411.ch. The "ads bloc...
Thu, 29 Jun, 2017 at 6:05 PM