FIXED: I have Windows 10. When I try to install AdBlock in Edge, it tells me I need to upgrade Windows.

You are probably seeing this because your version of Windows 10 doesn't support Edge extensions. Please make sure that you're using the most recent release of Windows 10 Anniversary (either the stable public release or the Windows Insider Preview) with all patches and updates installed.


To check your Windows version:

  1. Press the Windows + R keys to open the Run command.
  2. Type Winver and press Enter.
If you have the Windows 10 Anniversary update, you should see "Version 1607" (or higher).




save image

R
Rhana is the author of this solution article.

Did you find it helpful? Yes No

Send feedback
Sorry we couldn't be helpful. Help us improve this article with your feedback.