Start a new topic

[Workaround] Youtube videos not showing video but playing audio (Confirmed)

I had this problem where youtube videos were not showing but the audio was playing when Adblock is on. After some google searching, I came across this page, which explained that many people were having this problem and it listed some steps to try to fix it.


In these situations, I have figured out how to block the ad on youtube and still get the video to play like normal. I am posting this so that hopefully Adblock can code a solution to it, and so that in the meantime, everyone else can start getting around this issue.


[Concept]

So when the youtube page loads, it tries to load the ad, which gets blocked, then I believe a script checks to see if the ad showed correctly, and if it didn't, it does not show the video. This script that does the check, only checks to see if the webpage has access to the media file of the ad. So if we allow access to just the ad's media file, the ad will still not play (because adblock also blocks the mechanism that shows the ad), and the script allows the video to play because we passed the check.


[How To Use This Knowledge]

When you get one of these youtube videos where only the audio plays, click on the Adblock icon on your toolbar and click on "Show all requests" (currently on Chrome, this prompts you to hit Ctrl+Shift+I and click on the Adblock tab). Reload the page. At the top of the Adblock tab is a dropdown box that says "all", click on it and select "blocked". This shows the list of all items that Adblock blocked. Find the first one of type "Media" that is from an external site, mouse over that item in the list, and click on "Add exception" on that item.


Now refresh the page. If it was the correct item, then the video should load fine now with no ad. If you look at the list of exceptions in Adblock, you can turn that one exception rule into one that will work for any videos that use that same ad provider.


For instance, here is an exception that I added:


"@@||ads-pd.nbcuni.com/tvn/PGPB0816000H_ENT/PGPB0816000H_ENT_0796.mp4"


We clean this up to say:


"@@||ads-pd.nbcuni.com/tvn/*"


Now any youtube videos using this same ad provider will have their ad blocked and you can watch the video without any issues. I hope this helps!





1 person likes this idea

Hi hexicgrind,


Thanks for sharing your solution with us! Thank you as well for the clear instructions. I'll add this to our troubleshooting article right now. :)


Stay awesome,


Rhana Cassidy

AdBlock Community Manager


P.S. I'd love to send you a little token of our appreciation. Would you feel comfortable sharing your snail mail address with us? I promise we'll never use it for any other purpose. If you are, please send it in an email to help@getadblock.com and be sure to include your name. Thanks!

Hey, thanks for that solution! I'll make sure to use that with my diagnostics in the future :) As for Rhana's request... Let's just say it's something you can't get anywhere else, and very few people have it. And yes, I do have one myself :)
:) Rhana

 

Here are a couple of other methods, if the issue still persists:

 

Method 1: Sign out of your YouTube (Google) account

 

The YouTube black screen issue often occurs when a user is watching the video with his or her account logged on. You can try signing out of your account and see if the video can play normally. To sign out, click the Account icon in the upper right corner of the YouTube page and then click Sign out.


Method 2: Disable hardware acceleration


Hardware acceleration means assigning some processing tasks to purpose-specified computer hardware like GPU, instead of your CPU. This can boost the performance of related software.

 

But hardware acceleration can sometimes bring about unexpected issues. If you have enabled hardware acceleration on your web browser, the YouTube videos may not be able to play normally. So, you can try disabling hardware acceleration on your browsers and see if this works for you.

 

(The steps below show you how to disable hardware acceleration on Chrome and Firefox)

 

A. If you are a Google Chrome user:

 

1) Click the menu button in the upper right corner. Then select Settings.

2) Click Show advanced settings at the bottom. 

3) In System section, uncheck Use hardware acceleration when available. 

4) Restart your browser. 

 

B: If you are using Firefox:

 

1) Click the menu button in the upper right corner and then click Options.

2) Click Advanced. Then uncheck Use hardware acceleration when available. 

3) Restart your browser. 

 

After you restart your browser, play a YouTube video and see if this method works. This answer from Google might help too.


Hi Kaushalmalkan11,


Those suggestions are in our troubleshooting article, but thanks for the easy-to-follow summary! :)


Warm regards,


Rhana Cassidy

AdBlock Community Manager

Hey,


I have to give credit to hexicgrind for the great suggestion and to Kaushalmalkan11 for the summary - couldn't have put them better myself!

 

I'd also like to add another update to the story from my own experiences.

 

I've not actually seen this bug recently in Chrome 62 and 63, although I didn't deploy these workarounds (which are great tips!) - it's still working fine even with my souped up measures, which are:

 

AdBlock on my Chrome 63 install

A handful of Custom Filters I've crafted as Anti-AdBlock countermeasures for several stubborn sites

The "It's Not Important" and "AAK-Cont" userscripts loaded into Tampermonkey

Plus one or two other things that Rhana will announce soon...

 

Your own mileage may vary as this is just my own experiences. Unfortunately I can't really simulate every possible scenario, but it's possible this particular bug might have been fixed somewhere down the line.


Would you be ok to try updating to the latest version of Chrome and the latest version of AdBlock without these fixes and workarounds and see if it's working now. If so then great - please let Rhana know! But if not do feel free to re-apply the fixes and report back :)


Oh, and I've another thing to add for Rhana,


I would suggest uninstalling the following programs from all your devices, even if they don't have any issues:

Microsoft Silverlight

RealPlayer (in actual fact ALL RealNetworks programs can/should be thrown into the Recycle Bin!)

Apple QuickTime Player

Adobe Shockwave Player

Adobe Flash Player

Safari (Windows only!)

Adobe Air (this one depends on individual users, if you're not using it then you can live without it)

Or any other legacy Plugin (doesn't apply to Browser Extensions like AdBlock, they're a different type!)


The reason I advise getting rid of them, is that they are all unsupported now, or about to go unsupported. You don't need those anymore and the browsers pretty much block them all. Since they serve no other purpose, you can safely uninstall just about all of them.


Chrome has a special version of Flash Player built in, so you don't need Adobe Flash for Chrome - it will also be automatically uninstalled from Chrome at the same time as Adobe pulls the plug on Adobe Flash Player in 2020.


Even then, Chrome automatically grabs the special version only if you actually need it. If you've never gone to a site in Chrome that uses Flash, you won't have Chrome's version of Flash installed at all ;)


Oh, and one more thing, you don't need to fiddle with the old Chrome Web Apps from the Chrome Web Store anyway... They might be about to uninstall themselves in the next few months...

Hi Matthew,


Thanks as always! :) :)


Rhana

AdBlock Community Manager

I'm always keeping an eye on things ;)


Brace yourself... This is going to be a wild ride...


I went back into the Chrome Blog archives so I could dig up the blog post about Chrome Web Apps shutdown, which you can find here


And ask quick as a Flash (Player), I've also dug up this one from Adobe, plus this one from Apple/WebKit since you got lucky the machine also wants to pay out a Like from Facebook and a +1 from Google - even Chrome wants to play its part and Firefox also want to help out


At least this time Microsoft isn't letting Internet Explorer or Edge break the web as both of them will also drop Flash Player.


Safari for Windows was dropped several years ago, so I don't think many people use that version of Safari anymore. However, you should uninstall QuickTime Player if you're on Windows as it's no longer supported. Here's a guide with some advice


Phew... that was a lot clicks

Login or Signup to post a comment